WEM: after upgrade , Agent does not register with the cloud infrastructure server
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Article ID: CTX335543
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Updated On:
Description
- After running the configuration utility on the agent to migrate to the cloud WEM broker server it looses the connectivity.
- Checking the Citrix WEM Agent Host service debug logs show the below error
Event -> BaseBrokerClient`1.GetConnectorAuthContext() : Successfully acquired connector authentication context.
Exception -> ConfigurationDataSourcesHelper.CheckAgentBrokerServiceClient() : System.ServiceModel.CommunicationException : An error occurred while making the HTTP request to https://XXXXX.wem.cloud.com/AgentBrokerSvc/service. This could be due to the fact that the server certificate is not configured properly with HTTP.SYS in the HTTPS case. This could also be caused by a mismatch of the security binding between the client and the server.
Exception -> ConfigurationDataSourcesHelper.CheckAgentBrokerServiceClient() : System.Net.WebException : The underlying connection was closed: An unexpected error occurred on a send.
Exception -> ConfigurationDataSourcesHelper.CheckAgentBrokerServiceClient() : System.IO.IOException : Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host.
Exception -> ConfigurationDataSourcesHelper.CheckAgentBrokerServiceClient() : System.Net.Sockets.SocketException : An existing connection was forcibly closed by the remote host
Exception -> ConfigurationDataSourcesHelper.CheckBrokerSvcConnection() : Broker Svc Check -> Failed
Exception -> AgentServiceHelper.OpenDataConnection() : Service appears to be Offline and no valid local cache found!
Environment
Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.
Resolution
1. Configure the group policy to setup the Proxy server on the WEM Agent.
OR
2. Create the below registry to setup Proxy server.
- Use command to setup registry as below:
New-ItemProperty -Path "HKLM:\SOFTWARE\Policies\Norskale\Agent Host" -Name "ProxyAdress" -Type String - Value "<http:Proxy server name>:<Port number>"
Problem Cause
Proxy not configured as expected
Additional Information
https://docs.citrix.com/en-us/workspace-environment-management/service/install-and-configure.html
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