Silent Command Line Upgrades of Workspace App without SelfService Fail Abruptly
book
Article ID: CTX335534
calendar_today
Updated On:
Description
Scenario: a command line installation of Workspace App where the /Silent parameter is used will simply stop within 30 seconds. This might occur during installations from the command line or through some management platform (for example: SCCM, or BigFix) or even Windows Active-Directory Group Policy settings.
Criteria:
- The ADDLOCAL parameter of the installation can have all components except for SELFSERVICE. If there is an installation with similar symptoms, but SELFSERVICE is present in ADDLOCAL, then it is a different issue.
- The issue only occurs during an upgrade from a supported version of Workspace App to another supported version of Workspace app. For example, an upgrade from Workspace App 1912 Cumulative Update (CU) 4 to CU5 or Workspace App 2106 to version 2109.1.
Both criteria must be met for this to be a match for the issue described in this article.
Evidence:
- No event logs - not even the Informational MsiInstaller logs that would normally post as a result of each component of Workspace App being installed.
- Trolley Express (Workspace App install Logs) - the Trolley Express log is the only log generated as a result of the installation attempt. Were this a successful install, the TrolleyExpress Log would be accompanied by logs for the C++ Runtime Libraries, as well as logs for each component of Workspace App that was installed.
- If a user performed these installs from the command line, then the files are stored under %temp% or C:\Users\{username}\AppData\Local\Temp
- If the installation was part of a push from a management platform, usually it will be done under the LOCAL SYSTEM context. The logs would then be stored under C:\Windows\Temp.
- The name of the folder containing the logs begins with CtxInstall.
- Open the Trolley Express Log on and verify the the command line used during the installation. Look for mistakes (for example, if ADDLOCAL was used, then spaces before or after the comma (,). the * Command Line: entry in the log appears within the first 10 lines of the log itself.
- Does the command line contain ADDLOCAL? If it does, was SELFSERVICE not included?
- If both are true, then we are on the path to the issue found here.
- However, if both are false, then the issue is caused by a different root cause.
- The screen capture below shows an example of the command line entry in the Trolley Express Log.
- Scroll to the end of the log and look for the following messaging:

No installation of Self Service found.
Cannot continue. Writing error for Receiver, prior to exit.
Upgrade unsuccessful: To upgrade, either use force-upgrade switch or manually uninstall older version and the install latest
Exit code is 1602 (called with 1602)
Another way to see the issue, would be to take the same command line installation and
remove the
/Silent parameter. Upon doing so during an upgrade, the following error dialog will be shown.

Finally, it doesn't matter how the Workspace App installer is named -- one could use
CitrixWorkspaceApp.exe or
CitrixWorkspaceAppWeb.exe. The same symptoms and results occurred regardless of the name.
Resolution
The issue has been addressed by a code change (CVADHELP-18790) that has been included in Workspace App 1912 CU6.
Problem Cause
A code defect in the installer allowed the installation to end prematurely because the SELFSERVICE component had not been included in the ADDLOCAL parameter.
Workarounds:
- Use the /forceinstall parameter as part of the upgrade.
- A manual install (which will result in the Citrix Workspace dialog box shown above), but clicking OK will allow the install to proceed as planned.
Was this article helpful?
thumb_up
Yes
thumb_down
No