End Users Prompted for App Registration Consent With Workspace App when using Azure AD
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Article ID: CTX331455
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Updated On:
Description
When End Users attempt to authenticate into Citrix Cloud Workspaces using Citrix Workspace App versions 2002 - 2109 the client devices are presented with the Azure App Registration Consent page, that will not allow them to proceed to Application/Desktop Enumeration.
- Web Browsers will continue to function without a Consent Prompt and enumeration will succeed
- Workspace App 1912 will continue to function without a Consent Prompt and enumeration will succeed
Resolution
There are two methods of bypassing this issue if electing to use Workspace App
- Use the Citrix Workspace App LTSR 1912CU# instead of versions 2002-2109
- Use a Registry Key on the Client Device under HKLM\Software\WOW6432Node\Citrix\Dazzle
- REG_SZ | LongLivedTokenSupport | Value: false

Once the Registry Key is in place, restart the Client Device for the item to take effect and the prompt for consent should no longer occur when using Workspace App 2002-2109
Problem Cause
This is being classified as a known issue at this time, and this serves as a temporary workaround until the issue is corrected in one of the next subsequent versions beyond Workspace App 2109
Additional Information
https://docs.citrix.com/en-us/citrix-workspace-app-for-windows/about.html#support-for-conditional-access-with-azure-ad-technical-preview
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