Uninstalling 7.15 LTSR VDA Breaks Access To Network Locations Over SMB From The Machine

Uninstalling 7.15 LTSR VDA Breaks Access To Network Locations Over SMB From The Machine

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Article ID: CTX331148

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Updated On:

Description

  • Uninstalling 7.15 LTSR VDA breaks access to network locations over SMB from the machine. This impacted the access to UPM profiles as the profile path as well as the path for the home drive was not accessible.

SMB1
  • Internet access and RDP access to the server are not affected.
  • The issue begins as soon as 7.15 LTSR VDA uninstalls and remains even after the installation of the 1912 LTSR CU2 VDA. No other issues are seen during upgrade.

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

Removed the "PvsVmAgent" entry manually from the DependOnService of Lanmanserver and LanmanWorkstation service registry.

Problem Cause

Checked the Services on the VDA and found that Server service as well as Workstation service failed to start with the message "Error 1075: The dependency service does not exist or has been marked for deletion" as entry for PvsVMAgent was not removed from DependOnService of Lanmanserver and LanmanWorkstation service registry on VDA uninstall.

Reverted the snapshot of the VDA prior to uninstallation and found that under LanmanServer and LanmanWorkstation Service registry key there were two PvsVmAgent entries one as PvsVmAgent and other as PvsVMAgent. This explained why one entry of PvsVmAgent was still left behind even though PvsVmAgent service was actually not present causing the service start to fail resulting into SMB access issues.

SMB2


SMB3

The root cause of presence of two instances of PvsVmAgent is unknown. The VDA was upgraded from an older 7.x version to 7.15, which might have caused this.
 

Additional Information

PvsVmAgent service on VDA not updating the machine account password locally
https://support.citrix.com/article/CTX249833