Endpoint Management server is not capturing the mobile device number for devices

Endpoint Management server is not capturing the mobile device number for devices

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Article ID: CTX331087

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Updated On:

Description

Citrix Endpoint Management is not able to detect the mobile device number from enrolled devices

Resolution

Citrix Endpoint Management can get the device properties from Settings app of the device. All the properties including Serial Number, IMEI, etc. can be fetched from the device settngs itself. 

Mobile number visibility depends on Sim card Carrier and phone model as well. Please verify with your carrier to get the number visibility enabled. In addition, ensure the following:
  • Ensure that there is a valid SIM card installed on the device. Also, ensure it's not an iPad without a SIM card.
  • In case the phone number status is Unknown on Android or iOS devices, MDM cannot fetch and display the phone number on the server. If on the device settings you can see the mobile number, XenMobile will show the contact number 

Problem Cause

Multiple causes as per below:
  1. No SIM card installed on device.
  2. Carrier does not allow phone number visibility
  3. My phone number shows as Unknown on device Settings > About Phone.