USB Scanner Is Not Being Automatically Redirected Within ICA Sessions

USB Scanner Is Not Being Automatically Redirected Within ICA Sessions

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Article ID: CTX330881

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Updated On:

Description

Automatic Redirection of USB Scanner Is Not Working Through ICA Sessions (The USB Scanner Must Be Always Redirected Manually)

Resolution

  • Make sure the Citrix Policy Settings below are enabled and are being applied to the correct Machine Object of your Citrix environment:
    • Client TWAIN Device Redirection > Allowed
    • Client USB Device Redirection > Allowed
    • Client Plug and Play Device Redirection > Allowed
  • The Scanner Drivers must be up to date within the Local Endpoint using Workspace App.
  • Make sure the following settings are enabled within “Citrix Workspace Preferences > Connections > Generic USB Devices”:
    • When a session starts, connect devices automatically
    • When a new device is connected while a session is running, connect the device automatically

Problem Cause

The required Generic USB Devices Settings are disabled

Additional Information

All component versions supported by the Product Lifecycle Support per Vendor: