Citrix Provisioning Services - vDisk Version Promotion Results In Failed Boot

Citrix Provisioning Services - vDisk Version Promotion Results In Failed Boot

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Article ID: CTX330683

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Updated On:

Description

After a vDisk version promotion Target Devices cannot successfully boot from the version.  The Target might BSOD or hang at the UEFI splash screen.  The vDisk version promotion prior to attempting to boot a device may appear to take a long time or cause a console error.  The Provisioning servers from which the console action took place show Event ID 55 NTFS Disk errors.  

Deleting the version, creating a new version and promoting the version without making any changes continues to result in the same subsequent boot failures.

Environment

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Resolution

This is a known issue in PVS 7.15 LTSR, 1912 LTSR and all supported version until release 2106 where this issue is resolved.  The fix released in 2106 will be available in 1912 LTSR CU5.

Workaround  #1:
Disable KMS and Cached Secrets Cleanup (CSC) in the vDisk properties.

Workaround #2:
Pre-create a new vDisk within a given store manually with a 4k sector size to avoid this behavior.

Workaround #3
Move the vDisk to a local volume on the PVS Servers (distributed HA).

Workaround #4:
Upgrade to PVS 1912 CU5 or version 2106.

Problem Cause

The problem is caused by the vDisk sector size being 512e while residing on 4Kn sector based storage, where being presented to PVS as a CIFs share.  During the vDisk "promote" action in the console the PVS Server will mount the vDisk quickly to perform actions required by CSC and KMS.  PVS fails to handle the file properly resulting in disk misalignment, then vhdx file corruption.  

Additional Information

See when/if PVS enables Read-Modify-Write (RMW) within the OS.  RMW can lead to streaming degradation and overall disk handling performance issues
https://support.citrix.com/article/CTX250229