User Profile Error - The volume is too fragmented to complete this transaction in Applayer Image
book
Article ID: CTX328198
calendar_today
Updated On:
Description
"User Profile Service service failed the sign-in. User profile cannot be loaded". Error : The volume is too fragmented to complete this transaction
Environment
This software application is provided to you as is with no representations, warranties or conditions of any kind. You may use and distribute it at your own risk. CITRIX DISCLAIMS ALL WARRANTIES WHATSOEVER, EXPRESS, IMPLIED, WRITTEN, ORAL OR STATUTORY, INCLUDING WITHOUT LIMITATION WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE AND NONINFRINGEMENT. Without limiting the generality of the foregoing, you acknowledge and agree that: (a) the software application may exhibit errors, design flaws or other problems, possibly resulting in loss of data or damage to property; (b) it may not be possible to make the software application fully functional; and (c) Citrix may, without notice or liability to you, cease to make available the current version and/or any future versions of the software application. In no event should the software application be used to support ultra-hazardous activities, including but not limited to life support or blasting activities. NEITHER CITRIX NOR ITS AFFILIATES OR AGENTS WILL BE LIABLE, UNDER BREACH OF CONTRACT OR ANY OTHER THEORY OF LIABILITY, FOR ANY DAMAGES WHATSOEVER ARISING FROM USE OF THE SOFTWARE APPLICATION, INCLUDING WITHOUT LIMITATION DIRECT, SPECIAL, INCIDENTAL, PUNITIVE, CONSEQUENTIAL OR OTHER DAMAGES, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. You agree to indemnify and defend Citrix against any and all claims arising from your use, modification or distribution of the software application.
Resolution
Option 1:1. Create a new version in the OS layer.
2. Goto C Drive properties.
- Tools - Run Error Checking and scan. - If any error on the scan run chkdsk /f /r from the command prompt.
- Optimize and defragment drive - Optimize.
3. Ran the above tools and Shutdown to finish the layer.
4. Use the updated layer to publish an image.
Option 2: (PVS vDisk)
1. Make a copy of the vDisk.2. Mount the vDisk on any server. Open Diskmanagement -> Action -> Attach VHD and select the vDisk file. 3. Once the disk is mount go to the Disk properties.
- Tools - Run Error Checking and scan. - If any error on the scan run chkdsk /f /r from the command prompt.
- Optimize and defragment drive - Optimize
4. Run the above and once done Detach the disk.
5. Import the updated vdisk into PVS and move the production to test.
Problem Cause
Fragmentation issue
Was this article helpful?
thumb_up
Yes
thumb_down
No