Citrix App Layering | Start Menu does not respond to left click on Windows 10 when template is published via Azure Connector

Citrix App Layering | Start Menu does not respond to left click on Windows 10 when template is published via Azure Connector

book

Article ID: CTX327900

calendar_today

Updated On:

Description

Start menu does not respond to left click for VDI's created from a template published via the Azure connector
The start menu may respond on first logon - but will always fail on second and subsequent logons
After logon we see the following events in the application event logs:
image.png

image.png

Resolution

When publishing a template to Azure to be used with any citrix provisioning system MCS or PVS (you would not be using the PVS connector in this case) you must use the "MCS for Azure Connector" not the "Azure Connector"
 

Problem Cause

Depending on the connector used to publish a template from the ELM a number of image processing operations will take place.
In this case a "uniservice" dependency is added to several windows services when an image is published via the "MCS  for Azure connector", this operation does not occur if using the "Azure connector"
These dependencies are required in order to ensure Userlayer/ application layers are mounted prior to start menu creation. 
Without these dependencies in place the services will start prior to userlayer/application layer mount and as a result the start menu will present this failure