"Unable to Launch Resource" error while switching to HTML5 client

"Unable to Launch Resource" error while switching to HTML5 client

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Article ID: CTX327882

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Updated On:

Description

With App protection enabled, if you switch to HTML5 client mid-way into the session/ beginning of the session all the protected and unprotected apps will be enumerated but when you click on launching the session, the below message will appear, which will lead to this document.

Resolution

When you access the Workspace site using browser with option of 'Apps and desktops will launch in your web browser or via HTML5 client', launch of protected resources is not supported through this method.
Follow the solution by adding the extension and launching the protected resources via web browser. This will only work via workspace browser to the workspace store when the launch preference in workspace store is to use Citrix Workspace App

For the protected resources to launch, please follow the below steps,

1. Go to Account Settings -> Advanced -> Use Workspace App



2. Install Browser Extension from the link given below, if installed, check if it is enabled.

3. After installing /enabling the web extension, please re-login.

Problem Cause

When you access the Workspace site using browser with option of 'Apps and desktops will launch in your web browser or via HTML5 client, protected resources are not supported to launch through this method.
Follow the solution by adding the extension and launching the protected resources via web browser. This will only work via workspace browser to the workspace store when the launch preference in workspace store to use Citrix Workspace App

Additional Information

eDoc:  https://docs.citrix.com/en-us/tech-zone/learn/poc-guides/app-protection-policies.html#configuration---delivery-group