Web Extension Required error when launching resources via HTML5 mode

book

Article ID: CTX327881

calendar_today

Updated On:

Description

  • You are not able to launch resources (apps or desktops from browser) due to a lack of web extension. If you see this modal dialog and are not able to launch application protected resource

    image.png
 

Resolution

Follow the below steps-

  1. Download browser extension from below link:
  2. After installing /enabling the web extension, please re-login.

Note: For other browsers, we will provide corresponding links eventually. If the issue persists even with the extension installed, further troubleshooting will be required. In this case, you can contact the Technical Support team to assist with diagnosing and resolving the problem.


Problem Cause

When you are trying to launch resources in Workspace via the Browser and the required extension is not present, then the above message pops up. When you access the Workspace site using browser with option of 'Apps and desktops will launch in your web browser or via HTML5 client, protected resources are not supported to launch through this method. Follow the solution by adding the extension to launch the protected resources via web browser. This will only work via workspace browser to the workspace store when the launch preference in workspace store to use Citrix Workspace App and not when using web receiver option from workspace store via browser

Issue/Introduction

HTML5 launch will fail if the required extension is not installed.