Citrix Provisioning Services - Target Device(s) Hang After 96 Hours With No PVS License

Citrix Provisioning Services - Target Device(s) Hang After 96 Hours With No PVS License

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Article ID: CTX326643

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Updated On:

Description

After a license server upgrade to support PVS 1912 LTSR from 7.15 LTSR Target Devices may immediately report entering "grace period".   After 96 hours of uptime the Target Device may appear to freeze. Target Device hangs or freezes are typically first found in the Studio console by a CVAD administrator as an unregistered machine.  The Target Device CPU appears maxxed out in the hypervisor console.  A Target Device is hung or no longer responding to keyboard or mouse clicks through RDP or its native console.  The Device may or may not respond to ping request.

There are multiple reasons you may encounter this error.  CDF logging, enabled by default in Provisioning Services 1912 LTSR , can supply you the licensing error preventing the PVS Server from providing the Target Device with a valid device license.  

This Target Device Freeze after 96 hours without a good license currently effects all supported versions of Provisioning Services.  

Environment

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Resolution

There are multiple reasons you may encounter this error and gathering CDF traces can help you determine which fix is required.

1.  Reinstall the License Server component on the existing Host or introduce a new Licensing Server. CDF traces will show the error, Error: LM_SERVERLONGGONE.  This roughly translates to the license server not recognizing the PVS version and rejecting all requests.

2. Download and install the appropriate Enterprise, Platinum or specific OS Device license for Provisioning Services.  The CDF logs can report an error, Error: LM_NOFEATURE.  This may indicate that your Enterprise license is not being read if indeed present or that you are running a device license for the incorrect operating system, for instance you have a Target Device with a Server OS running but the license only allows Desktop OS.

 

Problem Cause

Citrix is currently investigating the Target Device hang behavior after 96 hours of uptime, this is not expected behavior.  However the Target Device can hang itself under the scenario where the BNDevice can no longer update its licensing state according to the license availability as a security mechanism.  This hang after 96 hours of perpetually being unlicensed appears to be related. There may be other licensing based reasons for the Target Device inability to obtain a proper license, follow the CDF traces, fixing the license problem will prevent this hang scenario.

1.  On rare occasions after a licensing server upgrade to accommodate the change from PVS 7.15 LTSR to 1912 LTSR the licensing server rejects request from PVS as it attempt to get a license for the respective Target Device(s).  This occurs directly after the Citrix Licensing Server upgrade that has assumed to have not installed properly.  Please disable any security or AV client to prevent third party intervention.

2.  There is a known issue in PVS 7.15 LTSR where licensing is not always properly enforced.  Some folks incorrectly running a Server OS with a PVS Desktop OS based license may now find that the changes in PVS 1912 LTSR prevent this from happening.  If you find yourself in this scenario please contact your sales representative to obtain proper licensing.