Citrix UPM Logs are not generating in the correct format

Citrix UPM Logs are not generating in the correct format

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Article ID: CTX324723

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Description

Citrix UPM logs generating a default filename of userprofilemanager.log in the location  C:\windows\system32\logfiles\UserProfileManager instead of the #_pm.log.

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

1. Grant the “Domain Computers” with “Modify” permission on the UPM profile log Share path.

2. To resolve the Hostname issue on the Logfile for Windows 10 Machine Update your "Domain Name" under the below registry keys.

    Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Domain

    Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\NV Domain

3. Restart the Citrix Profile Management Service.

Problem Cause

1. Domain computers did not have the right to Modify and write on the UPM Profile log share location,
2. The following registry entries were not being populated correctly on the Windows 10 machines

 
Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Domain

Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\NV Domain