ICA Launch Gets Stuck At "Please wait for the Local Session Manager" Due To SSPI Call Delays

ICA Launch Gets Stuck At "Please wait for the Local Session Manager" Due To SSPI Call Delays

book

Article ID: CTX324114

calendar_today

Updated On:

Description

  • Intermittently when users click on published application icon, nothing happens. Users have to to click multiple times to launch the application .
  • Sometimes, on clicking the application icon the session initates but gets stuck at "Please wait for the Local Session Manager" for a while  and then disappears.

 

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

  • Disabled SSPI (Security Support Provider Interface) using below key on the VDA as a workaround.The below registry key is to bypass the delegation detecting logic . This registry key is just for mitigating the issue and isolating the issue root cause. Adding the below registry key may or may not address other Active Directory/DNS issues causing SSPI related errors or delays.
  • If the registry key workaround works, you still need to work with Microsoft investigate the Active Directory issue.


HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Citrix\Logon
Value Name: DisableSSPI
Value Type: REG_DWORD
Value:   1

 

Problem Cause

Connectivity issue with Active Director causing delay with RDP and citrix launch session.

Additional Information


https://support.citrix.com/article/CTX479747