Citrix App Layering | Unable to access the packaging VM in Azure portal while adding a version to OS Layer imported from Citrix Hypervisor/VMware base ELM

Citrix App Layering | Unable to access the packaging VM in Azure portal while adding a version to OS Layer imported from Citrix Hypervisor/VMware base ELM

book

Article ID: CTX322925

calendar_today

Updated On:

Description

Issue while adding version to OS Layer, wherein the packaging vm of the OS Layer revision does not allow the Citrix Admin to RDP or ping to it.
Cannot RDP nor Ping to this packaging vm and on the boot diagnostics in Azure, we see a black screen.
 

Environment

Citrix is not responsible for and does not endorse or accept any responsibility for the contents or your use of these third party Web sites. Citrix is providing these links to you only as a convenience, and the inclusion of any link does not imply endorsement by Citrix of the linked Web site. It is your responsibility to take precautions to ensure that whatever Web site you use is free of viruses or other harmful items.

Resolution

Please enable RDP in the OS layers before exporting/importing them into Azure.
This can be found under "Remote Desktop Settings", or via registry key here: https://docs.microsoft.com/en-us/azure/virtual-machines/windows/prepare-for-upload-vhd-image#update-remote-desktop-registry-settings .
The above article also tells you how to enable ping, and the entire thing is useful for preparing an image to run in Azure.
 

Problem Cause

Pre-requisites missing while exporting & importing OS Layers into Azure ELM. 

Issue/Introduction

This article talks about issues related to Export/Import process of OS Layer into ELM hosted in Microsoft Azure.

Additional Information

https://docs.microsoft.com/en-us/azure/virtual-machines/windows/prepare-for-upload-vhd-image#update-remote-desktop-registry-settings