Citrix Director - 7.15 LTSR: Exporting session trends from Citrix Director by selecting last one month option, generates only last 7 days data

Citrix Director - 7.15 LTSR: Exporting session trends from Citrix Director by selecting last one month option, generates only last 7 days data

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Article ID: CTX322807

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Updated On:

Description

You may see only 7 days of data while exporting session trends from Citrix Director by selecting last one month 

Resolution

Restart the Monitor service on DDCs to resolve the issue.

Please follow these steps to confirm if your environment only saves 7 days of historical data :

1). Check the following value in DB(Both of them default value is 90):

[Monitor DB name].[Monitor].[Configuration].[GroomSessionsRetentionDays]

[Monitor DB name].[Monitor].[Configuration].[GroomApplicationInstanceRetentionDays]

2). If the above value is right, restart  Monitoring services in all DDCs.

3). Record current data in the following table

[Monitor DB name].[MonitorData].[Session]

[Monitor DB name].[MonitorData].[ApplicationInstance ]

4). Wait for about 2-3 days, check if there is more than 10 days' historical data following table.

Check if any data older than 10 days has not been deleted.

 

Problem Cause

It is caused by the Monitor service try to load GroomSessionsRetentionDays value from DB, but the DB is in a block state at that time, so it will be assigned the default value 7 days. This way it will store only 7 days' historical data.

Further, the root cause of this issue is caused by the stability of the database itself. Currently, we may get some clues from the Event Viewer log as a Proactive measurement. It is hard to know when the DB connection may have lost because the connection will be restored soon in most cases.