XenMobile Android Enterprise & iOS devices failed to enroll after ADC upgrade to 13.0-82.41+ or 12.1-62.23+
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Article ID: CTX322608
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Updated On:
Description
In a deployment of Citrix ADC (Gateway) + XenMobile Server on-premise.
When Citrix ADC upgrade to 13.0-82.41+ or 12.1-62.23+ version or
XenMobile Android Enterprise and iOS device enrollment will fail.
Environment
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Resolution
Please refer to the following Citrix ADC doc to enable SSO configuration for XenMobile Gateway Virtual server.
https://docs.citrix.com/en-us/citrix-adc/current-release/aaa-tm/single-sign-on-types/enable-sso-for-auth-pol.htmlGUI Configuration Guide:
- Part 1: Configure a traffic policy that enabled http SSO:
13. Navigate to Citrix Gateway > Policies > Traffic, select Traffic Profiles tab, and click Add.
- Part 2: After configured traffic policy, please bind it to XenMobile Gateway Virtual Server.
Navigate to Citrix Gateway> Virtual Servers, select XenMobile Gateway and Edit.

Then Scroll DOWN to the bottom to find
Policies section to add binding a traffic policy:


Select the traffic policy we just created, for example named as
vpn_tf_pol, then bind it with a high Priority value like 63000

CLI Configuration Guide:
Demo configuration commands follows:
//Creating traffic policy with SSO enabled
add vpn trafficaction vpn_tf_act http -SSO ON
add vpn trafficpolicy vpn_tf_pol true vpn_tf_act
//Binding traffic policy to XenMobile Gateway Virtual server
bind vpn vserver _XM_XenMobileGateway -policy vpn_tf_pol -priority 63000
Problem Cause
It's because ADC 13.0 after 13.0-82.41 and 12.1-62.23 has disabled weak SSO types like Basic/Digest/NTLM at global level as Security Enhancement.
We shall enable these SSO for XenMobile Gateway Virtual Server.
Issue/Introduction
ADC disabled weak SSO types globally.
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