Unable to create or update a hosting connection in Citrix Cloud

Unable to create or update a hosting connection in Citrix Cloud

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Article ID: CTX318833

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Updated On:

Description

For a new hosting connection (even with the same URL as existing connection), below error is received - 

"The host server cannot be contacted. Check that the connection has a valid host address, and that the host server is powered on and working properly. Url Invalid."

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This happens when we have Proxy enabled on the Cloud connectors.

Resolution

1. Run command netsh winhttp import proxy source =ie on the cloud connector’s elevated command prompt. Restart the OS to make the changes effective.

2. Use the below command on the Cloud Connector (elevated command prompt - Run As Admin) to ensure BITS is using the proxy properly. Replace the proxy:port with actual proxy server and port in use here with the Host URL added in the bypass list.
bitsadmin /util /setieproxy networkservice MANUAL_PROXY "proxy:port" "bypass list"
Example : 
bitsadmin /util /setieproxy networkservice MANUAL_PROXY “someproxy.mydomain.com:port” “hostserver.mydomain.com;<local>”

3. Restart the cloud connector and run the connectivity test to confirm it passes

4. Repeat the same steps above one by one on each Cloud connector of a resource location

5. Once done, add the new hosting connection or update the existing one

Problem Cause

The host URL wasn't added to the bypass list for the proxy for BITS service, hence the Cloud connector was not able to communicate with the Host server properly.

Additional Information

Connector Connectivity Check failure : https://support.citrix.com/article/CTX291400 
Connector Web Proxy : https://support.citrix.com/article/CTX221823
How to use BITSAdmin : https://docs.microsoft.com/en-us/windows-server/administration/windows-commands/bitsadmin-util-and-setieproxy