Citrix Cloud - CSP getting error while trying to add customer through Cloud Portal.

Citrix Cloud - CSP getting error while trying to add customer through Cloud Portal.

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Article ID: CTX318324

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Updated On:

Description

When we try adding a new customer in the Citrix Cloud portal, an error is displayed after we click on 'Finish.' The error reads: "Unable to reach server. Please try again of contact Citrix Cloud Support"

Resolution

Removing dots from company name resolves the issue.

Problem Cause

On reviewing the developer traces, it could be identified what is causing the issue:

 

"text": "{\"message\":\"The request is invalid.\",\"modelState\":{\"model.StsAccount.CompanyName\":[\"The given value 'XYZ XYZ B.V.' is not allowed for CompanyName\"]}}

In the above scenario, as the error states, the issue is happening because the CSP has entered dots in the company name.