ADM and Director Intergration missing Network HDX data: Error "No details are available" or blank page

ADM and Director Intergration missing Network HDX data: Error "No details are available" or blank page

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Article ID: CTX318298

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Updated On:

Description

Running Citrix ADM 13.0 (latest) and attempting to integrated the network function into our Citrix Director 1912.

Attempted to use both HTTP and HTTPS.
WIth HTTP the network tab on director is blank.
With HTTPS it say no details are available.

The following guide was used: https://docs.citrix.com/en-us/xenapp-and-xendesktop/7-15-ltsr/director/hdx-insight.html

Using HTTPS ::

Using HTTPS

Network capture trace shows Director Servers sends a FIN and interrupt TLS Handshake with ADM Server.

TLS flow Request from ADM Server
==========================
Transport Layer Security
    TLSv1.2 Record Layer: Handshake Protocol: New Session Ticket
    TLSv1.2 Record Layer: Change Cipher Spec Protocol: Change Cipher Spec
    TLSv1.2 Record Layer: Handshake Protocol: Encrypted Handshake Message
    

Response TLS from Director Server
==========================
Transmission Control Protocol, Src Port: 52282, Dst Port: 443, Seq: 342, Ack: 4300, Len: 0
    Source Port: 52282
    Destination Port: 443
    [Stream index: 0]
    [TCP Segment Len: 0]
    Sequence Number: 342    (relative sequence number)
    Sequence Number (raw): 1163837986
    [Next Sequence Number: 343    (relative sequence number)]
    Acknowledgment Number: 4300    (relative ack number)
    Acknowledgment number (raw): 1444382645
    0101 .... = Header Length: 20 bytes (5)
    Flags: 0x011 (FIN, ACK)


Using HTTP :: Browser shows a blank page, no errors or details.

Resolution

If HTTPS port 443 is used, verify the following ::
  1. Use the ADM FQDN instead or IP when configuring director script to reference ADM.
  2. Replace the ADM TLS cert with a cert trusted by Director Server.
  3. Make sure there are no FW blocking https:443 between Director and ADM.
  4. If network capture trace from Director shows TLS handshake problems (and you don't know how to fix them) use HTTP only instead HTTPS when integrating director and ADM. Engage Citrix Support if assistance is required.

If HTTP port 80 is used, verify the following ::
  1. Relax browser security policies by enable display of "mixed content" For Firefox follow this article https://support.mozilla.org/en-US/kb/mixed-content-blocking-firefox

Problem Cause

Possible root causes when HTTPS protocol is used
=====================
- FireWalls blocking required ports between Director & ADM (HTTP:443)
- [*] Make sure Director trust the ADM Server certificate presented, otherwise replace ADM Server cert with a Director server trusted certificate.
- IP used to reference ADM instead of FQDN when running Director integration script.


Possible root causes when HTTP protocol is used
=====================
- Newer browser security policies block "mixed content" by default.