TDICA Error 1019 - Application frozen

TDICA Error 1019 - Application frozen

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Article ID: CTX318206

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Description

When users is opening an application from NSGW, the application opens correctly. When a user is opening the application from a desktop session CWA (19.12.0.119) application is frozen. When checking event log we see TDICA 1019 event, when we disable the widows FW this application is not frozen and works correctly. Inbound Rules for CGP and UDP are enabled.

Resolution

As the application was launching it was clear that ICA was ok 
If the firewall was turned off on the VDA app was working as expected.
Because HDX/multi-stream was set we need UDP Port 2598* open as per our docs for open ports

Once the inbound rule was set the app (Notepad) worked as expected. 

Problem Cause

local firewall on the VDA

Additional Information

https://docs.citrix.com/en-us/tech-zone/build/tech-papers/citrix-communication-ports.html