Issue with Activation Lock Bypass command Endpoint management console for iPhone only.

Issue with Activation Lock Bypass command Endpoint management console for iPhone only.

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Article ID: CTX318177

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Updated On:

Description

Issue: 

On supervised iPhone devices, when we send Activation lock Bypass command from console, it will always results in failure and we can see the error message under Device Details -> Delivery Groups. 
Issue is seen only iPhone models and on iPad it works fine. 

We have confirmed Activation lock enabled is set to Yes, and we can see the Activation lock bypass code value on console as well. 

Log snippet: 

 2021-06-01 T13:15:18.361+0000 | "user.id=test@citrix.com" | WARN | test.xm.cloud.com | com.citrix.ios.security.impl.DeviceServicesWorkersImpl | Unable to bypass the activation lock (device: {id:"1", serialNumber:"F1234356", imei:"35 12004 12345 5", activeSyncId:"AXAXAYAYAYA", osFamily:"iOS", strongId:"JCFGBH1", Last user name:"test@citrix.com "Test"", mamDeviceId: "Abcd1234hhjjkkk=", mamRegistered: "false", mamReady: "false", appWipe: "false", deviceType: "iPhone", depRegistered: "true", asmDepRegistered: "false", asmDepShared: "false", depAccountId: "1", depProfileId: "1", depProfileStatus:"PUSHED"}recoveryKey:"null"}macDepAdminGUID:"null"}): 
response code: 404
com.sparus.nps.EWException: <?xml version="1.0" encoding="UTF-8"?><ns:escrowKeyDeviceServicesResponse version="1" xmlns:ns="http://www.apple.com/cds/mdmescrowKeyDeviceServices/xml"><error code="1002" message="com.apple.cds.cyclops.mdm.MDMServiceException: No entry found for device F1234356:3512004123455:3512004123455"/></ns:escrowKeyDeviceServicesResponse

 

Resolution

Engineering teams are working on this issue and as a workaround, we should use option of entering code generated on CEM console manually till fix is identified by Apple and our engineering teams.

Problem Cause

Issue with Apple integration with CEM console which are affecting Activation LockBypass code command for iPhone devices only.