CVAD 1912 CU2 || Unable launch applications / Desktop from client - Unknown client error 1110, Proxy error

CVAD 1912 CU2 || Unable launch applications / Desktop from client - Unknown client error 1110, Proxy error

book

Article ID: CTX316642

calendar_today

Updated On:

Description

User can access to Published app locally. .User cannot access published apps or desktop through VPN from client machine.Ping and access Domain server, local DNS, etc working fine.

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

Solution:
      Create the Resgitry key as below as we are seeing MTU packet reset happens through UDP over the VPN network. Enabling the MTU discovery will resolve the issue.
To enable or disable EDT MTU Discovery on the VDA

  1. Set this registry key:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\Wds\icawd
    Name: MtuDiscovery
    Type: DWORD
    Data: 00000001
  2. Restart the VDA and wait for the VDA to register.

To disable EDT MTU Discovery, delete this registry value and restart the VDA


Problem Cause

>> 17334,2,2021/05/24 15:45:27:73145,1476,5064,wfica32.exe,4,HPC_ICA_ENG,udttransport.c,807,InitSocketOptions(),9,Information," Disabling MTU discovery for socket: 1124435463",""
>> 17335,2,2021/05/24 15:45:27:73237,1476,5064,wfica32.exe,4,win,core.cpp,428,CUDT::setOpt,9,Information,"m_iMSS set to 1500",""

MTU packets are reset over UDP in network. VPN connection is causing the issue.

Additional Information

https://docs.citrix.com/en-us/citrix-virtual-apps-desktops/technical-overview/hdx/adaptive-transport.html