Citrix Workspace app showing white screen, screen does not refresh, app resize issues on client machines running Intel Iris Xe-Treiber video driver
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Article ID: CTX316568
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Description
-Citrix Workspace App won’t load/refresh, it stays just white screen
-It is possible to refresh the apps by resizing the workspace app, but that is not a viable solution.
-All version of Citrix workspace app is affected 20, 21.3, 21.4 TP
Resolution
workaround in place for the moment: -the following registry entry on the client: HKEY_CURRENT_USER\SOFTWARE\Microsoft\Avalon.Graphics\ Name: DisableHWAcceleration Type: DWORD Value: 1
The disable hardware acceleration option enables you to turn off hardware acceleration for debugging and test purposes. When you see rendering artifacts in an application, try turning off hardware acceleration. If the artifact disappears, the problem might be with your video driver.
https://docs.microsoft.com/en-us/dotnet/desktop/wpf/graphics-multimedia/graphics-rendering-registry-settings?view=netframeworkdesktop-4.8
Problem Cause
-The affected client machines are running Intel Iris Xe video driver,
-The Iris Xe video drive on client PC is not compatible/supported with CWA
-If we disable the Intel Iris Xe driver in device manager, the issue is resolved
-Hence applying above registry enables to turn off hardware acceleration. If the artifact disappears, the problem might be with your video driver.
Issue/Introduction
Citrix Workspace app does not refresh on any version of CWA on client machines running Intel Iris Xe video driver
The CWA can be resize to see the content, but screen remain white until you resize again
If we disable the intel video driver the CWA app works fine.
Hence workaround is to disable the Hardware accelaration on affected client machine
HKEY_CURRENT_USER\SOFTWARE\Microsoft\Avalon.Graphics
Name: DisableHWAcceleration
Type: DWORD
Value: 1
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