Error when starting an App / Exe on a redirected Client Mapped Drive - Windows cannot access \\Client\C$\Application.exe

Error when starting an App / Exe on a redirected Client Mapped Drive - Windows cannot access \\Client\C$\Application.exe

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Article ID: CTX312495

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Updated On:

Description

When starting an Application on the redirected Client Mapped Drive,
You may be faced with this error:

Windows cannot access \\Client\C$\Application.exe
You do not have permissions to access \\Client\C$\Application.exe. Contact your network administrator to request access.

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Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

In HKLM\SOFTWARE\Policies\Citrix\CDMSettings\ (create CDMSettings if it doesn’t exist),
Create the following Key:

Name: ExecuteFromMappedDrive

Type: DWORD

Value: 1 to allow permission and 0 to deny permission on mapped drives

The change takes effect for sessions connected after the registry edit.


Problem Cause

as per https://docs.citrix.com/en-us/citrix-virtual-apps-desktops/devices.html#mapped-client-drives

There is a change in VDA 20.06 to allow an executable to launch on a Client Mapped Drive
Citrix Virtual Apps and Desktops 7 2006 is the first version to contain this registry location. Earlier versions of Citrix Virtual Apps and Desktops used a different registry location.