Issues with Storefront Authentication via iFrame on SharePoint - SSO & Username + Password do not work
book
Article ID: CTX312407
calendar_today
Updated On:
Description
Authentication works if you connect directly to Storefront but it fails when accessingStorefront via iFrame on Sharepoint,
You might encounter these errors when Authenticating:
- SSO > fails with error "Unable to log on with the account that you used to log on to the computer"
- Manual (Username+Password) fails with "Unable to process your request"
When reviewing the "Citrix Delivery Services" Event Logs on the StoreFront Servers you will see these 2 Events,
Event ID 17 - An authentication request was made before establishing a web session. This typically occurs when sticky load-balancing between client and StoreFront is misconfigured,
No session for authentication:
Event ID 3 - An error occurred during authentication,
No session for authentication:
Resolution
Change 1 line in the web.config file in:
C:\inetpub\wwwroot\Citrix\<StoreName>Web
From:
<sessionState timeout="20" />To:
<sessionState cookieSameSite="None" cookieless="false" timeout="360" />
Problem Cause
Cookies are not being persisted from during the Authentication phase, it must be the same cookies user for List + Login,
When reviewing the StoreFront verbose logs we can see that a new Cookie is used for Login, which is different to the one that was used for List:

The same cookie must be used for both steps to ensure that the correct user is Authenticated,
As a result of this, StoreFront fails the Authentication as the cookie passed was not the same cookie used in the first step,
Which is why we receive the “No session for authentication" Error.
Additional Information
https://support.citrix.com/article/CTX139592
Was this article helpful?
thumb_up
Yes
thumb_down
No