Virtual Apps and Desktops: Users getting Temporary profiles with error "An unexpected network error occurred." in UPM logs
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Article ID: CTX312306
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Updated On:
Description
When a user logs in using a profile with Citrix UPM they receive a temp profile from the Window OS.
After checking UPM logs the following errors are presented:
"An unexpected network error occurred."
And/Or
within a ProcMon capture:
“NETWORK ERROR FileInformationClass: FileBothDirectoryInformation,”
Resolution
To enable UPM logging for troubleshooting purposes please refer to our docsNote: It is advised to you have Admins with permissions to the root UPM folder avoid performing Windows File Explorer Searches for files/folders.To resolve this issue open your vendors storage management console and locate FOLDER locks on the users pending profile path (IE. \\STORAGEShare\profiles\UPM\Username\Pending\UPM_Profile). Remove any locks on the Pending profile path.
Have the effected users log off of the Citrix Session on which they have a temp profile and log back in. The user should be presenting with their UPM Profile.
Problem Cause
Under some circumstances, if an (Admin) user with write permissions to a users pending folders preforms a search using windows file explorer in the root director of the UPM Share. The (Admin) user may cause FOLDERS to lock, this in turn prevents the pending folder from being written and on next user log in causes a temp profile to load due to data being present in the Pending folder.
Additional Information
***Avoid admins using the Windows File Explorer search in the root directory of UPM
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