Citrix DaaS: Session Launch Stuck At Blue Screen And Event Warning 1019

Citrix DaaS: Session Launch Stuck At Blue Screen And Event Warning 1019

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Article ID: CTX311251

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Updated On:

Description

  • As soon as application launch is initiated via native receiver, we see a logon banner and once we hit OK on the logon banner, the session stays stuck at a blue screen with spinning dots.
  • Issue was reproducible all the time with all the users.

spinningdot.PNG
  • Below event is logged on the VDA

Log Name:      System
Source:        TdIca
Date:          17-03-2021 17:20:13
Event ID:      1019
Task Category: None
Level:         Warning
Keywords:      Classic
User:          N/A
Computer:      zzz
Description:
The Citrix ICA Transport Driver connection from 10.203.129.156:57095 to port 2598 received an invalid packet during its SSL handshake phase.

  • From CDF traces captured from VDA found that Always prompt for password upon connection GPO is enabled.
33365,0,2021-03-17 17:20:22:82041,1216,928,svchost.exe(termsvcs),0,Rpm, ,1599,ctx::CSCSMgr::GetSessionAutologonCredentials4,9,Error,"ctx::CSCSMgr::GetSessionAutologonCredentials4: SSPIToken is an invalid handle, calling getCredentials",""

33366,0,2021-03-17 17:20:22:82042,1216,928,svchost.exe(termsvcs),0,Rpm, ,1605,ctx::CSCSMgr::GetSessionAutologonCredentials4,9,Information,"ctx::CSCSMgr::GetSessionAutologonCredentials4: Get user cred",""


33366,0,2021-03-17 17:20:22:82042,1216,928,svchost.exe(termsvcs),0,Rpm, ,1605,ctx::CSCSMgr::GetSessionAutologonCredentials4,9,Information,"ctx::CSCSMgr::GetSessionAutologonCredentials4: Get user cred",""

33372,0,2021-03-17 17:20:22:82048,1216,928,svchost.exe(termsvcs),0,Rpm, ,308,RpcCtxGetAutologonCredentials4,9,Information,"RpcCtxGetAutologonCredentials4: Require Prompt for Password",""
33373,0,2021-03-17 17:20:22:82048,1216,928,svchost.exe(termsvcs),0,Rpm, 71,ctx::BaseSession::~BaseSession,13,EntryExit,"EXIT ---- RpcCtxGetAutologonCredentials4",""

33374,0,2021-03-17 17:20:22:82052,6172,440,Unknown,-1,DLL,CtxLogonFilter.,1091,CoCtxLogonFilter::_getCtxClientCredentials,9,Error,"CoCtxLogonFilter::_getCtxClientCredentials:RPC call CtxGetAutologonCredentials4 returned : 2",""
33379,0,2021-03-17 17:20:22:82080,6172,440,Unknown,-1,DLL, ,1299,CoCtxLogonFilter::_getCtxClientCredentials,9,Information,"CoCtxLogonFilter::_getCtxClientCredentials: (exit)",""

33380,0,2021-03-17 17:20:22:82080,6172,440,Unknown,-1,DLL, ,421,CoCtxLogonFilter::UpdateRemoteCredential,9,Error,"CoCtxLogonFilter::UpdateRemoteCredential:_getClientCredential returns error hr=80004005",""



Procmon

17:20:22.8186535      svchost.exe       928       RegQueryValue  HKLM\SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services\fPromptForPassword          SUCCESS           Type: REG_DWORD, Length: 4, Data: 1

 

Resolution

Disabling the below GPO fixed the issue:

Computer Configuration – Policies – Administrative Templates – Windows Components – Remotes Desktop Services – Remote Desktop Session Host – Security – Always prompt for password upon connection


 

Problem Cause



The issue was caused due to GPO "Always prompt for password upon connection" being enabled.

 

Additional Information

https://www.citrix.com/blogs/2012/12/06/windows-login-prompt-when-launching-apps/