During DDC upgrade, Installer Wizard does not resume after reboot

During DDC upgrade, Installer Wizard does not resume after reboot

book

Article ID: CTX310996

calendar_today

Updated On:

Description

While upgrading, the installer wizard requires a reboot.
Post reboot, the installation does not continue.
If you attempt to launch the installation manually, nothing happens. 
You have the policy "Set the default behavior for AutoRun" configured to "enabled" and set to "Do not execute any autorun commands" 
Other possible symptoms: 
Application Event ID 1026 from .NET Runtime with the description: The process was terminated due to an unhandled exception.
Application Event ID 1000 from Application Error with

Faulting application: Citrix.Trust.exe
Faulting Module Name: KERNELBASE.dll
Exception code: 0xe0434352
Application Event ID 1009 from Citrix Trust Service with "Service startup failed with: System.Reflection.ReflectionTypeLoadException: Unable to load one or more of the requested types"

 

Resolution

The policy that is disabling Autorun is causing the installation to fail. The best way to disable the policy is to move the computer account to an OU where this policy is not in effect. The policy might also be applied through some WMI filter, or might even be configured locally. 

Another way to disable the policy is to configure a local group policy that disables this policy.  The local group policy is applied last, so will over-write the domain policy.
  1. Open Group Policy Editor on the local machine.
    1. Start MMC.exe. Ctrl-M to add/remove Snapins.
    2. Select Group Policy Object Editor.
    3. Click "Add" to select. Accept the default Group Policy Object "Local Computer".
    4. Click OK.
    5. You are now editing the local group policy of the computer.
  2. Browse to Local Computer Policy>Computer Configuration> Administrative Templates > Windows Components > AutoPlay Policies.
  3. Select "Set the default behavior for AutoRun" and choose "Disabled"
  4. Exit the MMC.
  5. Reboot the computer. 
There should be an AutoRun command in HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce that will launch and complete the installation.

Problem Cause

XenDesktop upgrade of DDC will fail if AutoRun is disabled. 
If you manually try to to continue by deleting "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce\!XenDesktopSetup" from the registry, you might find that other components are not configured after the next required reboot. For instance, the Citrix Trust Service might crash with a .NET application error for "unhandled exception".

Issue/Introduction

XenDesktop upgrade uses "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce" to continue the installation after a required reboot. An upgrade may fail if AutoRun is disabled.