Unable to Accept Administrator Invitation to Citrix Cloud

Unable to Accept Administrator Invitation to Citrix Cloud

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Article ID: CTX310818

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Updated On:

Description

When attempting to join Citrix Cloud as an Administrator, the web page will state one of the following messages:

  • "Cannot Complete Your Request."
  • "Unable to Process Your Request"
  • "There was an unexpected error"

Resolution

The administrator being added must have a Citrix.com account in order to be added to Citrix Cloud as an Administrator. End-users that are not Administrators do not require a Citrix.com account to log into Citrix Cloud Workspaces - however Administrators require a Citrix.com account to be allowed into Cloud.com.
 

Problem Cause

  • Citrix Cloud will pull the Administrator details from the Citrix.com account. The check from the Cloud Portal will utilize the Citrix.com account to validate the Organization ID (OrgID) of the business, the name of the Administrator, and the address. While most of these checks are done when the Cloud Account for the business is first created, new Administrators must have an existing Citrix.com account prior to the System allowing them into the Cloud Account.
  •  Once the Citrix.com Account is created successfully, the invitation can be accepted, and will allow them to authenticate.

Additional Information

https://docs.citrix.com/en-us/citrix-cloud/citrix-cloud-management/identity-access-management/add-admins.html