Citrix Director : Top 10 Process Table Does Not Populate Any Data After Upgrading to CAVD 1912 LTSR CU2

Citrix Director : Top 10 Process Table Does Not Populate Any Data After Upgrading to CAVD 1912 LTSR CU2

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Article ID: CTX310722

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Updated On:

Description

After Upgrading the Citrix Environment to Citrix Virtual Apps & Desktop 1912 LTSR CU2 unable to populate the Top 10 Processes under Historical Machine Utilization.

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Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

Steps 1 : 

If running the following command doesn't resolve the issue with Top 10 Processes enumerating in Citrix Director follow the Step 2 instructions.

Set-MonitorConfiguration -EnableDayLevelGranularityProcessUtilization $True 
Set-MonitorConfiguration -EnableHourLevelGranularityProcessUtilization $True
Set-MonitorConfiguration -EnableMinLevelGranularityProcessUtilization $True 


Step 2

Set or modify the following Registry on VDA:

1).HKLM\Software\Citrix\GroupPolicy\SaveRsopToFile Type : DWORD(32-bit) Value Data: 1

2).HKLM\Software\Citrix\GroupPolicy\SaveRsopToRegistry Type : DWORD(32-bit) Value Data: 0

3). Delete the original Policy "Enable process monitoring" and re-create it.

4). Restart the VDA Server / VDI Desktop or do a GPUPDATE /Force to push the policies on VDA machine. 

5). Restart Citrix Controllers (DDC) and Citrix Director Servers  

Note: If due to some reasons you are unable to restart the Citrix Controller Servers you may restart the Citrix Broker Service and Citrix Monitor Service.

6). Wait for about 10 minutes, then check the Top 10 process in Director.

7). The Top 10 Processes should show up.


NOTE : Last Option To Get The Issue Fixed is To Uninstall VDA Component and Install Again. 

Problem Cause

Ran Get-MonitorConfiguration and found that the below settings were set to False:

EnableDayLevelGranularityProcessUtilization                                                                             False                                                                                                                  
EnableHourLevelGranularityProcessUtilization                                                                            False                                                                                                                  
EnableMinLevelGranularityProcessUtilization                                                                             False         
 

Issue/Introduction

Top 10 Process Table Does not Populate Any Data Under Historical Machine Utilization even after enabling the following settings : Set-MonitorConfiguration -EnableDayLevelGranularityProcessUtilization $True  Set-MonitorConfiguration -EnableHourLevelGranularityProcessUtilization $True Set-MonitorConfiguration -EnableMinLevelGranularityProcessUtilization $True 

Additional Information

https://support.citrix.com/article/CTX233555