'Cannot start app' when StoreFront is configured for FAS/SAML authentication

'Cannot start app' when StoreFront is configured for FAS/SAML authentication

book

Article ID: CTX310635

calendar_today

Updated On:

Description

Launching an application or desktop fails with error ‘Cannot start app’  when StoreFront is configured for FAS/SAML authentication.  

On the Storefront servers, we see ‘Access Denied’ for AssertIdentity from FAS server.


On the FAS server, we could see that CA failed to issue certificate for UPN.

    

 

Resolution

Under ‘Enrollment agents’ tab in CA Properties, Make sure FAS server computer object is added.




 

Problem Cause

If the EA does not have the permissions to make a request, the CA will return a nonzero error.
Exception code - 0x80094009 

On the CA server, under ‘Failed Requests’ in certsrv.msc.. we see the below error,
CERTSRV_E_RESTRICTEDOFFICER