There was a problem adding an administrator When adding an AzureAD Administrator to Citrix Cloud
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Article ID: CTX310467
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Updated On:
Description
You may experience following error while adding/sending invite to an administrator with Azure AD identity provider in Citrix Cloud.
There was a problem adding an administrator. Please try again later.

Resolution
- Please collect browser HAR logs while reproducing the issue and share with Citrix Technical Support.
- Share Azure Active Directory OID for that account with Citrix Technical Support.
- Make sure to capture HAR logs for each account your are trying to add as an administrator in your Citrix Cloud.
- Make sure to share your Customer ID/Org ID along with HAR Logs or OID(s).
- An Escalated Support Case will be required so that the backend original AUTH OID can be removed. Once removed, the new Citrix Cloud AzureAD Admin invites will need to be sent out.
Problem Cause
Azure Active Directory OID might be associated to the user's previous email address. If an Citrix AzureAD Admin exists or is in use and the AzureAD Admin email address changes, this will cause the OID to also change. Given the OID has changed this then impacts our backend Auths associated with the original AzureAD Admin email address.
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