Adding Physical Devices to Citrix Cloud using the Provisioning Devices Export Wizard. "No Devices Found to Export"

Adding Physical Devices to Citrix Cloud using the Provisioning Devices Export Wizard. "No Devices Found to Export"

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Article ID: CTX310415

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Updated On:

Description

When attempting to add Physical Devices to Citrix Cloud using the Citrix Provisioning Devices Export Wizard. Getting a message "No Devices Found to Export" after selected the Device Collection to export. (Note: Physical Devices can also be a VM that will not be in a Power Managed Catalog.)

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Resolution

Delete and recreated the AD account for the PVS Target Device, so the AD information is added to PVS. To then allow you to export the device to Citrix Cloud. 

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Problem Cause

Missing Active Directory information. 
 
If any of the below AD information is missing you won't be able to export the Target Device. 

AD information you are looking for.

  • DomainName:
  • DomainObjectSID:
  • DomainControllerName:
  • DomainTimeCreated:


How to check if the domain information is missing for the Target Device with PVS console or PVS server with console.

1.  Open PowerShell as Admin and Load PVS Snap-In's

Import-Module "C:\Program Files\Citrix\Provisioning Services Console\Citrix.PVS.SnapIn.dll"
2. Check the PVS Target Device Information. (Replace TargetDeviceName with how the it how in the PVS Console)
Get-PvsDevice -DeviceName "TargetDeviceName"

 

    Issue/Introduction

    When attempting to add Physical Devices to Citrix Cloud using the Citrix Provisioning Devices Export Wizard. Getting a message "No Devices Found to Export" after selected the Device Collection to export.

    Additional Information


    Citrix Provisioning Export Devices Wizard
    https://docs.citrix.com/en-us/provisioning/current-release/configure/export-devices-wizard.html