User/Device License Fails To Checkout With A Space In The Username

User/Device License Fails To Checkout With A Space In The Username

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Article ID: CTX307845

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Updated On:

Description

  • UD (User/Device) License utilization not showing up in Studio under Licensing tab and neither through udadmin command udadmin -list .

License_Usage
  • Checked and confirmed that there was no issue in session creation due to licenses. Hence, issue was not with issuing licenses but rather with just license usage reporting.
  • Issue is seen with Citrix License Build 11.6.3 and above.
  • Captured CDF traces from the DDC and VDA while reproducing the issue i.e launching a new ICA session leveraging UD licenses.
DDC CDF
 
  • Searched for MFLic* In Broker CDF Traces to check for Licensing checkout calls during the session launch.
  • From DDC side CDF found that, the grace temporary license is issued successfully, although a syntax error is received during the license checkout. However, the ICA Connection succeeds successfully.
  • Checked for username and Device name sent for Licensing checkout and saw that the device name did not have any special characters but found that username had a space. All usersnames in customer’s environment had space between first and last name.

         5202,0,2021/01/20 11:13:38:21003,2136492,1744,0,lib,MFLic_LicAPI,1972,GetGraceLicense,9,Information,"GetGraceLicense: Vendor Str=;LT=Retail;GP=720;CL=VDS,VDA,VDE,VDP;SA=1;LP=90;ODP=0;NUDURMIN=2880;NUDURMAX=525600",""
        5203,0,2021/01/20 11:13:38:21003,2136492,1744,0,lib,MFLic_LicAPI,2058,GetGraceLicense,9,Information,"GetGraceLicense: LIC_REQ_TIMEOUT/LS_COMM_FAILURE",""


5204,2,2021/01/20 11:13:38:21019,3184,1744,0,lib,MFLic_LicOpThrd,1755,RecursiveCheckout,9,Information,"RecursiveCheckout: Flex request sent: UD:2020.0625#XDT_PLT_UD#A,U#FirstName LastName@ADS,D#6819B0FB;ESC000148362002 ?V:1.2","

 5205,2,2021/01/20 11:13:38:21019,3184,1744,0,lib,MFLic_LicOpThrd,1769,RecursiveCheckout,9,Information,"RecursiveCheckout: Flex Return Code(0)",""
 
 5206,2,2021/01/20 11:13:38:21019,3184,1744,0,lib,MFLic_LicOpThrd,1793,RecursiveCheckout,9,Information,"RecursiveCheckout: Success. A response is received for UD lic",""



5207,2,2021/01/20 11:13:38:21019,3184,1744,0,lib,MFLic_LicOpThrd,1794,RecursiveCheckout,9,Information,"RecursiveCheckout: Flex Return Code(0), response got UD:ERROR_SYNTAX|0 5 0 0",""


 

Resolution


Citrix is aware of this issue and they are working on creating a fix which will be  included in future Citrix  License Server versions.

The below workarounds are available:
 
  1. Create Usernames without spaces.
  2. Use the License Server build 30000 as a workaround.

This is documented under [LIC-3506] under Known issues in License server build 31000 and earlier.

https://docs.citrix.com/en-us/licensing/current-release/about/known-issues.html
 

Problem Cause

Because of known issue in the product, The UD (User/Device) license usage was not being reported because of space present in the username.