Launching Citrix Virtual Desktop or App Sessions Prompts via Citrix Workspace App "An Online Application is attempting to access information on a device attached to your computer"
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Article ID: CTX297102
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Updated On:
Description
When launching Citrix Virtual Desktops or Apps, users are prompted with:
- "An Online Application is attempting to access information on a device attached to your computer".
Resolution
To prevent the prompt from appearing, disable the following policies via your preferred method of managing policies in the environment:
- Citrix Studio
- Active Directory Group Policy
Configure the following Citrix Policies:
- "Auto Connect Client Drives" - set this policy to Disabled
- "Client USB Plug and Play Device Redirection" - set this policy to Prohibited
For additional information please review the following Citrix Documentation.
Problem Cause
This is by design when Client Drive and/or USB redirection policies are enabled. In the event the end users do not select an option that is remembered they will continue to receive said prompts.
Instruct end users how to proceed, or if it is deemed the subset of users do not need these features they can be disabled via policy.
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