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Article ID: CTX297024
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Updated On:
Description
While performing a upgrade by uninstalling the previous version of a Citrix Component and installing the newer version, it fails with the following error being logged in the Installation Logfile.
$ERR$ : XenDesktopSetup:CitrixProductHere failed to install, with internal error code 1714, failing action was "RemoveExistingProducts"
Resolution
- Verify there are no Citrix Components listed in Control Panel's 'Programs and Features' section.
- Download the Microsoft Installation Troubleshooter and run it as an Administrator.
- On the 'Having trouble with' section, select 'Uninstall'.
- Check the list for any Citrix Components that were not cleanly uninstalled.
- Select any remaining component and have the troubleshooter uninstall it.
- After cleaning up all leftover components, perform the installation normally.
Problem Cause
Some Citrix components from the older version might not have been cleanly uninstalled.