Unable to install Citrix Components with the error code 1714 - (Failing action was "RemoveExistingProducts")

Unable to install Citrix Components with the error code 1714 - (Failing action was "RemoveExistingProducts")

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Article ID: CTX297024

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Updated On:

Description

While performing a upgrade by uninstalling the previous version of a Citrix Component and installing the newer version, it fails with the following error being logged in the Installation Logfile.

$ERR$ : XenDesktopSetup:CitrixProductHere failed to install, with internal error code 1714, failing action was "RemoveExistingProducts"

Resolution

  1. Verify there are no Citrix Components listed in Control Panel's 'Programs and Features' section.
  2. Download the Microsoft Installation Troubleshooter and run it as an Administrator.
  3. On the 'Having trouble with' section, select 'Uninstall'.
  4. Check the list for any Citrix Components that were not cleanly uninstalled.
  5. Select any remaining component and have the troubleshooter uninstall it.
  6. After cleaning up all leftover components, perform the installation normally.

Problem Cause

Some Citrix components from the older version might not have been cleanly uninstalled.