On touch based client device keyboard does not pop-up when pressing on input fields on a Google Chrome

On touch based client device keyboard does not pop-up when pressing on input fields on a Google Chrome

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Article ID: CTX297015

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Description

When using a Touch-Input device (IPad, Android devices) and using a Google Chrome (or a Chromium based custom application) there are issues with keyboard auto pop-up. When touching the input fields inside the browser, the keyboard should pop up, but it does not. 

Resolution

We can force Chrome to expose its UI to automation by publishing Chrome with a command line: --force-renderer-accessibility

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Problem Cause

Newer versions of Google Chrome does not expose its UI elements to the Windows UI Automation Framework which Citrix uses to support touch functionality for desktop apps.

Please see https://www.chromium.org/developers/design-documents/accessibility for details.