Wem Agents cant sync the Cache. Error: "Cache sync failed with error: SyncFailed".

Wem Agents cant sync the Cache. Error: "Cache sync failed with error: SyncFailed".

book

Article ID: CTX296690

calendar_today

Updated On:

Description

Some WEM agents are unable to synchronize the WEM cache. When manually trying to sync the cache using the command - "AgentCacheUtility.exe -refreshcache" error, "Cache sync failed with error: SyncFailed" is received.

Resolution

  1. Add the below permissions for the WEM Service account
  • dbowner
  • dbwriter 
  • dbsecurityadmin
  1. Agents should now be able to successfully synchronize the cache from the WEM Broker.

Problem Cause

WEM Service account did not have appropriate permissions on the database level.