[Citrix NetScaler] Monitor DOWN with error: "No MIP/SNIP available to send the monitor probe"

[Citrix NetScaler] Monitor DOWN with error: "No MIP/SNIP available to send the monitor probe"

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Article ID: CTX292840

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Updated On:

Description

You may see services DOWN with error "No MIP/SNIP available to send the monitor probe". 

2168  14 PPE-0 MonServiceBinding_XXXXXXXXXX: DOWN; Last response: Failure - No MIP/SNIP available to send the monitor probe. Thu Dec 17 08:45:07 2020


 

Resolution

Suggest to check below configuration that may be incorrect: 

1. Make sure USNIP mode is enabled globally. 
2. Check route table for the next hop. At least one SNIP is in the same subnet with the next hop. 
3. If SNIP is actually in the same subnet with NSIP, make sure that SNIP and NSIP have the same netmask configured. 
4. Add more SNIPs if there are some port allocation failures. 

Problem Cause

"No MIP/SNIP" means there is no SNIP configured in the same subnet with next hop to destination by checking routing table. 

Possible Cause #1:
Global USNIP mode is disabled. 


Possible Cause #2: 
Indeed there is no valid SNIP configured. 

Possible Cause #3: 
The SNIP is in the same subnet with NSIP, but has a different netmask. e.g,

  • NSIP: 192.168.1.1/255.255.0.0
  • SNIP: 192.168.1.100/255.255.255.0

In above scenario, the SNIP 192.168.1.100 won't be used. 

Possible Cause #4: 
No free ports available for the SNIP and causes port allocation failures. Which can be observed from the following command: 

> stat tcp detail | grep allocation