Issues with Workspace Environment Management (WEM) after deprecation of the legacy sync framework

Issues with Workspace Environment Management (WEM) after deprecation of the legacy sync framework

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Article ID: CTX291425

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Updated On:

Description

Microsoft Sync Framework 2.1 reached End of Life on January 12, 2021. So, WEM has removed the legacy sync service based on that framework, and instead uses a new sync framework, Dotmim.Sync, an open-source sync framework. By default, the legacy sync service uses the port 8285, and the new sync service uses the port 8288.

How does this change impact you?

For cloud deployments:

The WEM agent whose version is earlier than 1911 cannot synchronize the agent cache through 8285.
The WEM agent whose version is 1911 or later can synchronize the cache with the infrastructure services through 8288.

For on-premises deployments:

The WEM agent whose version is earlier than 1912 cannot synchronize the cache through 8285.
The WEM agent whose version is 1912 or later can synchronize the cache with the infrastructure services through 8288.

Expected issues

After the deprecation of the legacy sync framework, you might encounter the following issues:

In the administration console, a red X icon might appear in the Synchronization State column for those agents.

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On the agent side, attempts to refresh the cache might fail with the following errors:

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In the agent host service debug log, you might find errors as follows:

 "System.ServiceModel.EndpointNotFoundException : Could not connect to net.tcp://10.158.217.96:8285/AgentLocalCacheSyncService/service. The connection attempt lasted for a time span of 00:00:01.0155903. TCP error code 10061: No connection could be made because the target machine actively refused it 10.158.217.96:8285. "

Influence surface (when do the issues occur?)

The issues impact Customers who enable one or more of the following offline mode settings and who have a large number of agents whose versions are earlier than 1911 (in the case of cloud WEM) or 1912 (in the case of on-premises WEM).

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Resolution

To resolve the issues, we recommend upgrading relevant agents to the latest version.

Problem Cause

Microsoft Sync Framework 2.1 reached End of Life on January 12, 2021. WEM has removed the legacy sync service based on that framework, and instead uses a new sync framework, Dotmim.Sync, an open-source sync framework. By default, the legacy sync service uses the port 8285, and the new sync service uses the port 8288.