ADC VPX on Azure Cloud : Unable to boot due to error : can't load 'kernel'
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Article ID: CTX290000
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Updated On:
Description
Citrix VPX on Azure is unable to boot.
In Azure console; Under Boot Diagnostics, it is observed that the booting is not completed.
The error "can't load 'kernel'" is seen and the VPX boots in single-user mode.

Resolution
Instance recovery is not possible from this state as Single user mode via Console is not supported for VPX in Azure Cloud. In this situation, we have 2 solutions:
- The Azure VM needs to be re-deployed.
- Adding support from backup and restore of VMs via disk snapshot and later OS Disk swap, we do find ADC can be reverted back to their previous running state with following steps and limitations:
* Steps: *
- Take snapshot of OS disk when ADC is in known good state.
- when needed to revert ADC to this running state, create a new disk from previously taken Snapshot.
- Make sure VM is in stopped(Deallocated) state
- Go to disk of VM and click on “Swap OS disk”
- select disk created from snapshot.
- Start VM
* Limitation: *
- Same VM instance has to be used for restore which was used for backup. Using different VM instance will lead to loss of subscription license or config mismatch.
- Make sure VM sub-resources are untouched like NIC and their corresponding private IPs. In case there are changes to VM sub-resources, same must be incorporated in ADC config for example updating NSIP/VIPs/SNIPs or routes.
Problem Cause
System unable to boot due to kernel file missing or corrupted.
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