Unable to start session in double hop environment
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Article ID: CTX289690
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Updated On:
Description
If you are using the Federation Authentication Service (FAS) for 1st hop authentication, the 2nd hop session might stop at "Please wait for Local Session Manager" or get an error "The user name or password is incorrect. Try again".
Environment
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Resolution
Enable FAS authentication on both the 1st and 2nd hops. Or disable FAS on the 1st hop.
Troubleshoot
How to check whether FAS is enabled with Event ViewerCheck if any
FAS related events are written in the event log
How to check whether FAS is enabled on StoreFrontExecute the following Powershell commnads on Storefront
> Get-Module "citrix.storefront. *" -ListAvailable | Import-Module
> $store = Get-STFStoreService -VirtualPath "/citrix/YOUR_STORE_NAME"
> Get-STFStoreLaunchOptions -StoreService $store
* Enter the actual store name for "YOUR_STORE_NAME"
Example:
SetNoLoadBiasFlag: False
AddressResolutionType: DnsPort
RequestICAClientSecureChannel: DetectAnyCiphers
IgnoreClientProvidedClientAddress: False
OverlayAutoLoginCredentialsWithTicket: False
OverrideIcaClientName: False
RequireLaunchReference: True
AllowFontSmoothing: True
ShowDesktopViewer: False
AllowSpecialFolderRedirection: False
ClientProxyPolicy: {}
RoutingPolicy: Citrix.StoreFront.Model.Store.RoutingPolicy
VdaLogonDataProviderName:
* In this case, VdaLogonDataProviderName is blank. Thus, FAS is not enabled.
How to enable or disable FAS on StoreFronthttps://docs.citrix.com/en-us/xenapp-and-xendesktop/7-15-ltsr/secure/federated-authentication-service.html#enable-the-federated-authentication-service-plug-in-on-a-storefront-store
Problem Cause
When an user logged on using FAS, Windows OS on the 1st hop VDA handles it like a smartcard logon.
Therefore, if the 2nd hop VDA is provided through another StoreFront using path-through authentication instead of FAS, then the 2nd hop VDA expects a smartcard logon.
As a result, pass-through authentication fails on the 2nd hop VDA.
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