App or Desktop disappears immediately after launch and session is left in Disconnected State

App or Desktop disappears immediately after launch and session is left in Disconnected State

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Article ID: CTX289586

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Updated On:

Description

App or Desktop disappears immediately after launch and session is left in Disconnected State on Studio and the VDA

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

-Under HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon registry key make sure there is only one cmstart.exe value specified in AppSetup. If multiple values of cmstart.exe are present, remove them.
-Reboot VDA

If AppSetup value does not exist, please create new String Value:

Type: REG_SZ

Value Name: AppSetup

Value Data: UsrLogon.cmd,cmstart.exe


Problem Cause

Under the registry  HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon,  AppSetup has multiple cmstart.exe values.

Additional Information