Unable to see Yubikey (5 Series) as a SmartCard device inside VDI session
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Article ID: CTX286891
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Updated On:
Description
When passing a SmartCard (Yubikey) through to a VDI host, the device seems to appear, but it is not detected as a SmartCard instead shows up as a Human Interface Device.
Environment
Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.
Resolution
YubiKey 5 Series is a composite device.
Need to enable following Citrix Workspace App for Windows policy to show all components.
Computer Configuration -> Administrative Templates -> Citrix Components -> Citrix Workspace -> Remoting client devices -> Generic USB Remoting -> SplitDevices
or
Set following registry on the client
Registry Path : HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Citrix\ICA Client\GenericUSB
Name: SplitDevices
Type: REG_DWORD
Data: 1
Problem Cause
YubiKey 5 Series is a composite device. Need to enable Citrix Workspace App for Windows policy to show all components.
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