Cannot add Machines to Machine catalog MCS
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Article ID: CTX286710
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Description
- Cannot add machines in existing machine catalog
- Error in the catalog's details: This machine catalog has the following warnings: Object reference not set to an instance of an object. Stack Trace: at Citrix.Orchestration.Base.PowerShellSdk.ModelConverters.SdkIdentityModelConverter.ToModelObject(SdkIdentity input) at System.Linq.Enumerable.WhereSelectListIterator`2.MoveNext() at System.Collections.Generic.List`1..ctor(IEnumerable`1 collection) at System.Linq.Enumerable.ToList[TSource](IEnumerable`1 source) at Citrix.Orchestration.Base.PowerShellSdk.ProvisioningSchemeService.BackgroundTasks.ADAccountCreationTask.RunTask() at Citrix.Orchestration.Base.PowerShellSdk.BackgroundTaskService.BackgroundTask.Task.Run()
Resolution
Delete the available AD accounts (stale entry) from Cloud studio through the following steps:
1. Right click on the machine catalog
2. Select "Manage AD accounts"
3. Select "available"
4. Delete the AD account
Problem Cause
Stale entry of an existing available AD account was present
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