ADC- HA Sync failure Error: Unable to connect to Primary. Please check the network connectivity from secondary to Primary

ADC- HA Sync failure Error: Unable to connect to Primary. Please check the network connectivity from secondary to Primary

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Article ID: CTX286560

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Updated On:

Description

HA sync between the nodes has failed after the ADC upgrade

Resolution

Complete the following steps on the primary node:

Install the ns-server-certificate :

1. Go to Traffic Management > SSL > Certificates > Server Certificates. 
2. Click on Install
3. Provide a certificate key pair name.
4. In the next tab click on Choose File and select Appliance from drop down menu.
5. Select "ns-server-certificate"
6. Click on install. 

To bind the cert, navigate to Traffic Management > Load Balancing > Service.
Select the "Internal Services" tab from the right side pane.
Bind the certificate to the SSL based RPC services.

After this services should be marked up and sync should be established between the nodes.
For more information on installing an SSL certificate refer to: https://docs.citrix.com/en-us/citrix-adc/current-release/ssl/config-ssloffloading.html#add-or-update-a-certificate-key-pair

Problem Cause

All the internal services were marked down as certificate binding went missing.

Additional Information



Please refer article : CTX282530 , that shows another reason that causes HA sync failure when upgrading to 13.0-64.35 and later from an earlier version.