Cloud - PermissionDenied when opening Studio (Citrix DaaS)

Cloud - PermissionDenied when opening Studio (Citrix DaaS)

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Article ID: CTX286248

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Updated On:

Description

  • Newly created full admin with rights in IAM cloud console, gets "You do not have the required permissions to perform this operation."  when attempting to open Studio. (Full text below the screenshot)
  • If another administrator is able to open Studio, inspection of the Administrators tab in Configuration shows that the full admin does not appear. 

 Exception: DesktopStudio_ErrorId : PermissionDenied Exception : System.UnauthorizedAccessException: Operation is not permitted GetServiceStatus at Citrix.Fma.Sdk.ServiceCommon.DelegatedAdminProvider.DemandPermission(String operation) at Citrix.Fma.Sdk.ServiceCommon.DelegatedAdminProvider.DemandPermission(String operation, ServiceRegistrationStates localAdminStates) at Citrix.Fma.Sdk.ServiceCore.ServiceCore.b__0() at Citrix.Fma.Sdk.ServiceCore.ServiceCore.CheckedCall[T](String name, Func`1 operation, Func`2 defaultValue, Enum code) Reason : UnauthorizedAccessException Message : Operation is not permitted GetServiceStatus Error Source : CitrixConfigurationService Sdk Error Message : Permission to perform the operation was denied. Sdk Error ID : Citrix.XDPowerShell.Status.PermissionDenied,Citrix.Configuration.Sdk.Management.Commands.GetConfigServiceStatusCommand ErrorCategory : PermissionDenied DesktopStudio_PowerShellHistory : GetControllerVersionsScript 11/9/2020 2:52:57 PM Get-ConfigServiceStatus -AdminAddress "CUSTIDXXXX.xendesktop.net:443" -BearerToken ******** Get-ConfigServiceStatus : Permission to perform the operation was denied. + CategoryInfo : PermissionDenied: (:) [Get-ConfigServiceStatus], UnauthorizedAccessException + FullyQualifiedErrorId : Citrix.XDPowerShell.Status.PermissionDenied,Citrix.Configuration.Sdk.Management.Commands.GetConfigServiceStatusCommand StackTrace: Citrix.Orchestration.Base.LogicModels.Exceptions.PermissionDeniedException You do not have the required permissions to perform this operation. at Citrix.Orchestration.Base.PowerShellInteraction.CmdletExecutionMethods.CreateException[T](ICommonLog logger, ExecutionResults`1 results, ICmdletExecutionHost host) at Citrix.Orchestration.Base.PowerShellInteraction.CmdletExecutionMethods.Execute[T](ISdkCmdlet`1 sdkCmd, ICmdletExecutionHost host, Boolean allowFailover) at Citrix.Orchestration.Base.PowerShellSdk.SiteService.Scripts.GetControllerVersionsScript.RunScript() at Citrix.Orchestration.Base.PowerShellInteraction.PowerShellScript`1.Run() at Citrix.Console.DeliveryCenter.UI.ViewModel.DesktopStudioViewModel.PoolModeLoadSiteState(String ccsLocation, IProgressReporter progressReporter) at Citrix.Console.DeliveryCenter.UI.ViewModel.DesktopStudioViewModel.PoolModeConnectToSite(String ccsLocation, Boolean safeForDispatcher, IProgressReporter progressReporter) at Citrix.Console.DeliveryCenter.UI.ViewModel.DesktopStudioViewModel.ConnectToSite(String ccsLocation, Boolean safeForDispatcher, IProgressReporter progressReporter) at Citrix.Console.Common.OperationTimer.TimeBlock(Action operation) at Citrix.Console.CommonControls.ProgressDisplay.GenericProgressOperationWithFeedBack.PerformOperationInternal() at Citrix.Console.CommonControls.ProgressDisplay.ProgressWindowOperation.PerformOperation() at Citrix.Console.CommonControls.ProgressDisplay.ProgressWindowViewModel.PerformAction(Action operationComplete) Inner Exception: StackTrace: System.UnauthorizedAccessException Permission to perform the operation was denied. at System.Management.Automation.MshCommandRuntime.ThrowTerminatingError(ErrorRecord errorRecord)

Resolution

Workaround: 
If another admin has access:
Remove the admin with the problem.
Re-Add the user as a Custom Admin.  This will trigger a resync of admins.
After the admin appears in the Administrators tab under configuration, you can change the admin to a Full Admin.

If not or the above workaround does not work: 
Open a Case with Citrix technical support.  Mention CCVADHELP-434
 

Problem Cause

Known Issue CCVADHELP-434

Issue/Introduction

When adding a new administrator to Citrix DaaS (formerly known as Citrix Cloud Virtual Apps and Desktops), the newly added administrator might not be able to open Studio.