File operations on Client Mapped Drive might fail in published apps or desktops
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Article ID: CTX285248
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Updated On:
Description
Some file operations executed in a published app or a published desktop session to a client mapped drive might fail with "permission denied".
User may also see the "File In Use" error in the local client machine:

The message says "The action can't be completed because the file is open in Citrix HDX Engine. Close the file and try again.
Environment
Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.
Resolution
The user facing this issue must end the Citrix session and then will be able to manage the file.
or
To stop the issue happening in published applications and published desktops with Client Mapped Drives add following registry on the VDI and reboot.
Registry Path : HKEY_LOCAL_MACHINE\System\Currentcontrolset\services\picadm\Parameters
Name: DisableFullStreamWrite
Type: REG_DWORD
Data: 0x01
Problem Cause
A client drive mapping performance feature introduced in Citrix Virtual Apps and Desktops version 1811 is the cause of the fault. This feature is enabled by default. [HDX-26969]
Issue/Introduction
Users copying, deleting, archiving, un-archiving files on a client mapped drive from in a published app or a published desktop might get errors and operations might fail.
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