CVAD Service: "Error: Citrix Workspace app cannot launch app" when launching from HTML5 client

CVAD Service: "Error: Citrix Workspace app cannot launch app" when launching from HTML5 client

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Article ID: CTX285175

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Updated On:

Description

This article is intended for Citrix administrators and technical teams only.
 
Non-admin users must contact their company’s Help Desk/IT support team and can refer to CTX297149 for more information.

Applications and Published Desktops launched with HTML5 client might fail. Users see "Error: Citrix Workspace app cannot launch app". Users might briefly see the "Connection Interrupted" flashcard. Administrators troubleshooting the issue may detect that the server suffered a BSOD and restarted.

Administrators able to collect a memory dump will find the Bugcheck Analysis that mentions "Caused by : icardd.dll".

Resolution

Update your VDA to version 2006 or higher.  Customers who need to use VDA version 1912 LTSR are advised to install 1912 CU 2 to address this issue.


Problem Cause

Known issue with Citrix icardd.dll graphic driver reported on Windows Server VDAs.

Issue/Introduction

Fast track article created to address a known issue impacting support